Excel keyboard shortcuts and
function keys
This article describes keyboard shortcuts, function keys, and some other common shortcut keys for
Microsoft Excel 2016 for Windows. This includes the shortcuts that you can use to access the ribbon.
Tip To keep this reference available when you work, you may want to print this topic. To print this
topic, press CTRL+P.
Notes



These shortcuts refer to the US keyboard layout. Keys for other layouts might not correspond
exactly to the keys on a US keyboard.
If a shortcut requires pressing two or more keys at the same time, this topic separates the
keys with a plus sign (+). If you have to press one key immediately after another, the keys are
separated by a comma (,).

Frequently used shortcuts
This table lists the most frequently used shortcuts in Excel 2016.

To do this
Close a spreadsheet
Open a spreadsheet
Go to the Home tab
Save a spreadsheet
Copy
Paste
Undo
Remove cell contents
Choose a fill color
Cut
Go to Insert tab
Bold
Center align cell contents
Go to Page Layout tab
Go to Data tab
Go to View tab

Press
Ctrl+W
Ctrl+O
Alt+H
Ctrl+S
Ctrl+C
Ctrl+V
Ctrl+Z
Delete key
Alt+H, H
Ctrl+X
Alt+N
Ctrl+B
Alt+H, A, then C
Alt+P
Alt+A
Alt+W

To do this
Format a cell from context menu

Press
Shift+F10, or
Context key

Add borders

Alt+H, B

Delete column

Alt+H,D, then C

Go to Formula tab

Alt+M

Keyboard shortcuts to navigate the Ribbon
If you're new to the Ribbon, the information in this section can help you understand the Ribbon's
keyboard shortcut model. The Ribbon comes with new shortcuts, called Access Keys. To see visible
key tips for the access keys, just press the Alt key.
To display a tab on the Ribbon, press the Alt key plus the letter for the tab—for example, press Alt+
N for the Insert tab or Alt+M for the Formulas tab. When you display a tab this way, the Key Tip
badges for that tab's buttons also appear. Then, press the key for the button you want.



To go to the Ribbon, press Alt, and then, to move between tabs, use the Right Arrow and Left
Arrow keys.
To hide the Ribbon so you have more room to work, press Ctrl+F1. Repeat to display the Ribbon
again.

Go to the access keys for the Ribbon
To go directly to a tab on the Ribbon, press one of the following access keys:

To do this
Open the Tell me box on the Ribbon and type a search term for assistance or
Help content.
Open the File page and use Backstage view.
Open the Home tab and format text and numbers and use the Find tool.
Open the Insert tab and insert PivotTables, charts, add-ins, Sparklines,
pictures, shapes, headers, or text boxes.

Press
Alt+Q, and then
enter the search
term.
Alt+F
Alt+H
Alt+N

Open the Draw tab to select a drawing tool, color and line thickness.

Alt+JI

Open the Page Layout tab and work with themes, page setup, scale, and
alignment.
Open the Formulas tab and insert, trace, and customize functions and

Alt+P
Alt+M

To do this
calculations.
Open the Data tab and connect to, sort, filter, analyze, and work with data.
Open the Review tab and check spelling, add comments, and protect sheets
and workbooks.
Open the View tab and preview page breaks and layouts, show and hide
gridlines and headings, set zoom magnification, manage windows and panes,
and view macros.

Press
Alt+A
Alt+R
Alt+W

Work in the Ribbon tabs and menus with the keyboard
To do this
Select the active tab of the Ribbon, and activate
the access keys.
Move the focus to commands on the Ribbon.
Move down, up, left, or right, respectively, among
the items on the Ribbon.
Activate a selected button.
Open the list for a selected command.
Open the menu for a selected button.
When a menu or submenu is open, move to the
next command.
Expand or collapse the Ribbon.
Open a context menu.

Press
Alt or F10. To move to a different tab, use
access keys or the arrow keys.
Tab or Shift+Tab
The Down Arrow, Up Arrow, Left Arrow, or Right
Arrow key
Spacebar or Enter
The Down Arrow key
Alt+Down Arrow
Down Arrow key
Ctrl+F1
Shift+F10 or
Context key (Windows keyboard only)

Move to the submenu when a main menu is open
or selected.

Left Arrow key

Reference: Keyboard shortcuts in Excel 2016
Navigate in cells: keyboard shortcuts
To do this
Move to the previous cell in a worksheet or the previous option in a dialog box.
Move one cell up in a worksheet.
Move one cell down in a worksheet.
Move one cell left in a worksheet.

Press
Shift+Tab
Up Arrow key
Down Arrow
key
Left Arrow key

To do this
Move one cell right in a worksheet.
Move to the edge of the current data region in a worksheet.
Enter End mode, move to the next nonblank cell in the same column or row as the
active cell, and turn off End mode. If the cells are blank, move to the last cell in the
row or column.
Move to the last cell on a worksheet, to the lowest used row of the rightmost used
column.
Extend the selection of cells to the last used cell on the worksheet (lower-right
corner).
Move to the cell in the upper-left corner of the window when Scroll Lock is turned
on.
Move to the beginning of a row in a worksheet. Home Move to the beginning of a
worksheet.
Move one screen down in a worksheet.
Move to the next sheet in a workbook.

Press
Right Arrow key
Ctrl+Arrow key
End, Arrow key

Move one screen to the right in a worksheet.
Move one screen up in a worksheet.

Alt+Page Down
Page Up

Move one screen to the left in a worksheet.

Alt+Page Up

Move to the previous sheet in a workbook.

Ctrl+Page Up

Move one cell to the right in a worksheet. Or, in a protected worksheet, move
between unlocked cells.

Tab

Ctrl+End
Ctrl+Shift+End
Home+Scroll
Lock
Ctrl+Home
Page Down
Ctrl+Page
Down

Format in cells: keyboard shortcuts
To do this
Format a cell by using the Format Cells dialog box.

Press
Ctrl+1

Format fonts in the Format Cells dialog box.

Ctrl+Shift+F or
Ctrl+Shift+P

Edit the active cell and put the insertion point at the end of its contents.
Or, if editing is turned off for the cell, move the insertion point into the
formula bar. If editing a formula, toggle Point mode off or on so you can
use arrow keys to create a reference.

F2

Add or edit a cell comment.

Shift+F2

Insert blank cells with the Insert dialog box.

Ctrl+Shift+Plus (+)

Display the Delete dialog box to delete selected cells.

Ctrl+Minus (-)

Enter the current time.

Ctrl+Shift+colon (:)

Enter the current date.

Ctrl+semi-colon (;)

Switch between displaying cell values or formulas in the worksheet.

Ctrl+grave accent (`)

To do this

Press

Copy a formula from the cell above the active cell into the cell or the
Formula Bar.

Ctrl+apostrophe (')

Move the selected cells.

Ctrl+X

Copy the selected cells.

Ctrl+C

Paste content at the insertion point, replacing any selection.
Paste content by using the Paste Special dialog box.

Ctrl+V
Ctrl+Alt+V

Italicize text or remove italic formatting.

Ctrl+I or Ctrl+3

Bold text or remove bold formatting.

Ctrl+B or Ctrl+2

Underline text or remove underline.

Ctrl+U or Ctrl+4

Apply or remove strikethrough formatting.

Ctrl+5

Switch between hiding objects, displaying objects, and displaying
placeholders for objects.

Ctrl+6

Apply an outline border to the selected cells.

Ctrl+Shift+ampersand
(&)

Remove the outline border from the selected cells.

Ctrl+Shift+underline (_)

Display or hide the outline symbols.

Ctrl+8

Hide the selected rows.

Ctrl+9

Hide the selected columns.

Ctrl+0

Use the Fill Down command to copy the contents and format of the
topmost cell of a selected range into the cells below.

Ctrl+D

Use the Fill Right command to copy the contents and format of the
leftmost cell of a selected range into the cells to the right.

Ctrl+R

Apply the General number format.

Ctrl+Shift+tilde (~)

Apply the Currency format with two decimal places (negative numbers in
parentheses).

Ctrl+Shift+dollar sign ($)

Apply the Percentage format with no decimal places.

Ctrl+Shift+percent (%)

Apply the Scientific number format with two decimal places.

Ctrl+Shift+caret (^)

Apply the Date format with the day, month, and year.
Apply the Time format with the hour and minute, and AM or PM.

Ctrl+Shift+number sign
(#)
Ctrl+Shift+at sign (@)

Apply the Number format with two decimal places, thousands separator,
and minus sign (-) for negative values.

Ctrl+Shift+exclamation
point (!)

Create or edit a hyperlink.

Ctrl+K

Check spelling in the active worksheet or selected range.

F7

Display the Quick Analysis options for selected cells that contain data.

Ctrl+Q

Display the Create Table dialog box.

Ctrl+L or Ctrl+T

Make selections and perform actions: keyboard shortcuts
To do this
Select the entire worksheet.
Select the current and next sheet in a workbook.
Select the current and previous sheet in a workbook.
Extend the selection of cells by one cell.
Extend the selection of cells to the last nonblank cell in
the same column or row as the active cell, or if the next
cell is blank, to the next nonblank cell.
Turn extend mode on and use the arrow keys to extend a
selection. Press again to turn off.

Press
Ctrl+A or Ctrl+Shift+Spacebar
Ctrl+Shift+Page Down
Ctrl+Shift+Page Up
Shift+arrow key
Ctrl+Shift+arrow key

Add a non-adjacent cell or range to a selection of cells by
using the arrow keys.

Shift+F8

Start a new line in the same cell.

Alt+Enter

Fill the selected cell range with the current entry.

Ctrl+Enter

Complete a cell entry and select the cell above.

Shift+Enter

Select an entire column in a worksheet.

Ctrl+Spacebar

Select an entire row in a worksheet.

Shift+Spacebar

Select all objects on a worksheet when an object is
selected.

Ctrl+Shift+Spacebar

Extend the selection of cells to the beginning of the
worksheet.

Ctrl+Shift+Home

Select the current region if the worksheet contains data.
Press a second time to select the current region and its
summary rows. Press a third time to select the entire
worksheet.

Ctrl+A or Ctrl+Shift+Spacebar

Select the current region around the active cell or select
an entire PivotTable report.

Ctrl+Shift+asterisk (*)

Select the first command on the menu when a menu or
submenu is visible.

Home

Repeat the last command or action, if possible.

Ctrl+Y

Undo the last action.

Ctrl+Z

Turn extend mode on and use the arrow
keys to extend a selection. Press again to
turn off. F8

Work with data, functions, and the formula bar: keyboard shortcuts
To do this

Press

Select an entire PivotTable report.

Ctrl+Shift+asterisk (*)

Edit the active cell and put the insertion point at the end of its contents.

F2

To do this

Press

Or, if editing is turned off for the cell, move the insertion point into the
formula bar. If editing a formula, toggle Point mode off or on so you can
use arrow keys to create a reference.
Expand or collapse the formula bar.

Ctrl+Shift+U

Cancel an entry in the cell or Formula Bar.

Esc

Complete an entry in the formula bar and select the cell below.

Enter

Move the cursor to the end of the text when in the formula bar.

Ctrl+End

Select all text in the formula bar from the cursor position to the end.

Ctrl+Shift+End

Calculate all worksheets in all open workbooks.

F9

Calculate the active worksheet.

Shift+F9

Calculate all worksheets in all open workbooks, regardless of whether they
have changed since the last calculation.

Ctrl+Alt+F9

Check dependent formulas, and then calculate all cells in all open
workbooks, including cells not marked as needing to be calculated.

Ctrl+Alt+Shift+F9

Display the menu or message for an Error Checking button.

Alt+Shift+F10

Display the Function Arguments dialog box when the insertion point is to
the right of a function name in a formula.

Ctrl+A

Insert argument names and parentheses when the insertion point is to the
right of a function name in a formula.

Ctrl+Shift+A

Invoke Flash Fill to automatically recognize patterns in adjacent columns
and fill the current column

Ctrl+E

Cycle through all combinations of absolute and relative references in a
formula if a cell reference or range is selected.

F4

Insert a function.

Shift+F3

Copy the value from the cell above the active cell into the cell or the
formula bar.

Ctrl+Shift+straight
quotation mark (")

Create an embedded chart of the data in the current range.

Alt+F1

Create a chart of the data in the current range in a separate Chart sheet.

F11

Define a name to use in references.

Alt+M, M, D

Paste a name from the Paste Name dialog box (if names have been
defined in the workbook.

F3

Move to the first field in the next record of a data form.

Enter

Create, run, edit, or delete a macro.

Alt+F8

Open the Microsoft Visual Basic For Applications Editor.

Alt+F11

Function keys
Key

Description

Key

Description

F1

Displays the Excel Help task pane.
Ctrl+F1 displays or hides the ribbon.
Alt+F1 creates an embedded chart of the data in the current range.
Alt+Shift+F1 inserts a new worksheet.

F2

Edit the active cell and put the insertion point at the end of its contents. Or, if editing is turned
off for the cell, move the insertion point into the formula bar. If editing a formula, toggle Point
mode off or on so you can use arrow keys to create a reference.
Shift+F2 adds or edits a cell comment.
Ctrl+F2 displays the print preview area on the Print tab in the Backstage view.

F3

Displays the Paste Name dialog box. Available only if names have been defined in the
workbook (Formulas tab, Defined Names group, Define Name).
Shift+F3 displays the Insert Function dialog box.

F4

Repeats the last command or action, if possible.
When a cell reference or range is selected in a formula, F4 cycles through all the various
combinations of absolute and relative references.
Ctrl+F4 closes the selected workbook window.

F5

Alt+F4 closes Excel.
Displays the Go To dialog box.
Ctrl+F5 restores the window size of the selected workbook window.

F6

Switches between the worksheet, ribbon, task pane, and Zoom controls. In a worksheet that
has been split (View menu, Manage This Window, Freeze Panes, Split Window command),
F6 includes the split panes when switching between panes and the ribbon area.
Shift+F6 switches between the worksheet, Zoom controls, task pane, and ribbon.
Ctrl+F6 switches to the next workbook window when more than one workbook window is
open.

F7

Displays the Spelling dialog box to check spelling in the active worksheet or selected range.
Ctrl+F7 performs the Move command on the workbook window when it is not maximized. Use
the arrow keys to move the window, and when finished press Enter, or Esc to cancel.

Key

Description

F8

Turns extend mode on or off. In extend mode, Extended Selection appears in the status line,
and the arrow keys extend the selection.
Shift+F8 enables you to add a nonadjacent cell or range to a selection of cells by using the
arrow keys.
Ctrl+F8 performs the Size command (on the Control menu for the workbook window) when a
workbook is not maximized.

F9

Alt+F8 displays the Macro dialog box to create, run, edit, or delete a macro.
Calculates all worksheets in all open workbooks.
Shift+F9 calculates the active worksheet.
Ctrl+Alt+F9 calculates all worksheets in all open workbooks, regardless of whether they have
changed since the last calculation.
Ctrl+Alt+Shift+F9 rechecks dependent formulas, and then calculates all cells in all open
workbooks, including cells not marked as needing to be calculated.
Ctrl+F9 minimizes a workbook window to an icon.

F10

Turns key tips on or off. (Pressing Alt does the same thing.)
Shift+F10 displays the shortcut menu for a selected item.
Alt+Shift+F10 displays the menu or message for an Error Checking button.
Ctrl+F10 maximizes or restores the selected workbook window.

F11

Creates a chart of the data in the current range in a separate Chart sheet.
Shift+F11 inserts a new worksheet.
Alt+F11 opens the Microsoft Visual Basic For Applications Editor, in which you can create a
macro by using Visual Basic for Applications (VBA).

F12

Displays the Save As dialog box.

Other useful shortcut keys
Key

Description

Key

Description

Alt

Displays the Key Tips (new shortcuts) on the ribbon.
For example,
Alt, W, P switches the worksheet to Page Layout view.
Alt, W, L switches the worksheet to Normal view.
Alt, W, I switches the worksheet to Page Break Preview view.

Arrow
Keys

Move one cell up, down, left, or right in a worksheet.
Ctrl+Arrow Key moves to the edge of the current data region in a worksheet.
Shift+Arrow Key extends the selection of cells by one cell.
Ctrl+Shift+Arrow Key extends the selection of cells to the last nonblank cell in the same
column or row as the active cell, or if the next cell is blank, extends the selection to the
next nonblank cell.
Left Arrow or Right Arrow selects the tab to the left or right when the ribbon is selected.
When a submenu is open or selected, these arrow keys switch between the main menu
and the submenu. When a ribbon tab is selected, these keys navigate the tab buttons.
Down Arrow or Up Arrow selects the next or previous command when a menu or
submenu is open. When a ribbon tab is selected, these keys navigate up or down the
tab group.
In a dialog box, arrow keys move between options in an open drop-down list, or
between options in a group of options.
Down Arrow or Alt+Down Arrow opens a selected drop-down list.

Backspace

Deletes one character to the left in the Formula Bar.
Also clears the content of the active cell.

Delete

In cell editing mode, it deletes the character to the left of the insertion point.
Removes the cell contents (data and formulas) from selected cells without affecting cell
formats or comments.
In cell editing mode, it deletes the character to the right of the insertion point.

End

End turns End mode on or off. In End mode, you can press an arrow key to move to the
next nonblank cell in the same column or row as the active cell. End mode turns off

Key

Description
automatically after pressing the arrow key. Make sure to press End again before
pressing the next arrow key. End mode is shown in the status bar when it is on.
If the cells are blank, pressing End followed by an arrow key moves to the last cell in the
row or column.
End also selects the last command on the menu when a menu or submenu is visible.
Ctrl+End moves to the last cell on a worksheet, to the lowest used row of the rightmost
used column. If the cursor is in the formula bar, Ctrl+End moves the cursor to the end of
the text.
Ctrl+Shift+End extends the selection of cells to the last used cell on the worksheet
(lower-right corner). If the cursor is in the formula bar, Ctrl+Shift+End selects all text in
the formula bar from the cursor position to the end—this does not affect the height of
the formula bar.

Enter

Completes a cell entry from the cell or the Formula Bar, and selects the cell below (by
default).
In a data form, it moves to the first field in the next record.
Opens a selected menu (press F10 to activate the menu bar) or performs the action for a
selected command.
In a dialog box, it performs the action for the default command button in the dialog box
(the button with the bold outline, often the OK button).
Alt+Enter starts a new line in the same cell.
Ctrl+Enter fills the selected cell range with the current entry.
Shift+Enter completes a cell entry and selects the cell above.

Esc

Cancels an entry in the cell or Formula Bar.
Closes an open menu or submenu, dialog box, or message window.
It also closes full screen mode when this mode has been applied, and returns to normal
screen mode to display the ribbon and status bar again.

Home

Moves to the beginning of a row in a worksheet.
Moves to the cell in the upper-left corner of the window when Scroll Lock is turned on.

Key

Description
Selects the first command on the menu when a menu or submenu is visible.
Ctrl+Home moves to the beginning of a worksheet.
Ctrl+Shift+Home extends the selection of cells to the beginning of the worksheet.

Page
Down

Moves one screen down in a worksheet.
Alt+Page Down moves one screen to the right in a worksheet.
Ctrl+Page Down moves to the next sheet in a workbook.
Ctrl+Shift+Page Down selects the current and next sheet in a workbook.

Page Up

Moves one screen up in a worksheet.
Alt+Page Up moves one screen to the left in a worksheet.
Ctrl+Page Up moves to the previous sheet in a workbook.
Ctrl+Shift+Page Up selects the current and previous sheet in a workbook.

Spacebar

In a dialog box, performs the action for the selected button, or selects or clears a check
box.
Ctrl+Spacebar selects an entire column in a worksheet.
Shift+Spacebar selects an entire row in a worksheet.
Ctrl+Shift+Spacebar selects the entire worksheet.
If the worksheet contains data, Ctrl+Shift+Spacebar selects the current region. Pressing
Ctrl+Shift+Spacebar a second time selects the current region and its summary rows.
Pressing Ctrl+Shift+Spacebar a third time selects the entire worksheet.
When an object is selected, Ctrl+Shift+Spacebar selects all objects on a worksheet.
Alt+Spacebar displays the Control menu for the Excel window.

Tab

Moves one cell to the right in a worksheet.
Moves between unlocked cells in a protected worksheet.
Moves to the next option or option group in a dialog box.
Shift+Tab moves to the previous cell in a worksheet or the previous option in a dialog

Key

Description
box.
Ctrl+Tab switches to the next tab in dialog box.
Ctrl+Shift+Tab switches to the previous tab in a dialog box.

